Published March 4, 2021

Important Information about Microsoft Power Automate Desktop

Reference ID: MC242840

MC242840 – We have detected an issue on some older versions of Microsoft Power Automate Desktop that we need your help to resolve.

How does this affect me?
We have identified that a certificate issue is causing failures when attempting to author, edit, or run flows using Power Automate Desktop versions 2.2 (December release), 2.3 (January release), and 2.4 (February release).

What action do I need to take?
If you installed a version of Power Automate Desktop prior to 02 March 2021, please update to the latest version, 2.5 (March release). Please see this documentation for assistance on updating.
Please contact Microsoft Support and reference ticket 230360184 if you need further assistance.

Petri Newsletters

Whether it’s Security or Cloud Computing, we have the know-how for you. Sign up for our newsletters here.

Latest Posts on Petri.com

Latest Podcast

00:00

/

00:00